Service issue for WOW customers
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted Aug 05, 2022 - 09:31 CDT
Update
All previous network issues have been resolved by WOW internet provider. Their teams are working diligently to resolve any remaining individual issues. https://twitter.com/WOWCare/
Posted Aug 04, 2022 - 15:16 CDT
Monitoring
WOW internet provider is experiencing service issues that affect many sites including RW. Wow is aware of the issue, and their team is working to resolve the problem as quickly as possible. https://twitter.com/WOWCare/
We will continue monitoring and will provide an update as soon as we have more details.
Posted Aug 04, 2022 - 09:22 CDT
This incident affected: Portals (Practice Portal, Enterprise Portal, Patient Portal), Forms (Forms), Communications (Patient Communications, Messenger, RW Phone), and Appointment Scheduling, Customer Login, Mobile App, Patient Payments, Virtual Visits.