Practice Portal Log In Issue

Incident Report for RevenueWell

Resolved

This incident has been resolved
Posted Mar 08, 2025 - 11:16 CST

Investigating

We are investigating an issue where users are unable to log into practice portal.
Posted Mar 08, 2025 - 11:05 CST
This incident affected: Portals (Practice Portal).