Issues Viewing Messages

Incident Report for RevenueWell

Resolved

The incident has been resolved. All customers should now be able to view their messages in RevenueWell Messenger without issue.
Posted Feb 27, 2025 - 08:49 CST

Identified

We have confirmed that there is an issue impacting RevenueWell Messenger and that this issue preventing users from being able to view/access their messages.

Our teams identified impacted area and are working to resolve. An update will be provided within one hour.
Posted Feb 27, 2025 - 08:05 CST

Investigating

We are investigating reports of some practices unable to view messages in RevenueWell Messenger.
Posted Feb 27, 2025 - 07:54 CST
This incident affected: Communications (Messenger).