Phone - Web phone not able to be activated in the browser.
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 15:36 CST
Monitoring
A fix has been implemented and systems have returned to normal operation. We'll continue to monitor before fully resolving this incident.
Posted Jan 18, 2024 - 11:18 CST
Identified
We have identified the issue and are working on resolving it.
Posted Jan 18, 2024 - 10:44 CST
Investigating
We are currently investigating the issue and will have an update shortly.
Posted Jan 18, 2024 - 10:37 CST
This incident affected: Communications (RW Phone).