RW Phone - Performance and Stability
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted Jul 29, 2024 - 16:16 CDT
Monitoring
Our service provider has restored phone service again. However, we will continue actively monitoring to ensure phone systems are stable.
Posted Jul 29, 2024 - 11:49 CDT
Identified
Our servicer provider is beginning to experience issues again. We are working with them to resolve.
Posted Jul 29, 2024 - 11:26 CDT
Monitoring
Our service provider has identified and addressed the issue and we are seeing functionality return to normal.

We will continue monitoring to ensure phone systems are stable.
Posted Jul 29, 2024 - 10:27 CDT
Update
We have confirmed the existence of an issue with our service provider and are jointly investigating.

Customers experiencing issues may have difficulty with inbound and outbound calls, and inability to log into your PBX.
Posted Jul 29, 2024 - 10:09 CDT
Investigating
We are investigating reports of RW phone availability issues and inability to log into the PBX.
Posted Jul 29, 2024 - 09:58 CDT
This incident affected: Communications (RW Phone).