Email Hosting Vendor Issue

Incident Report for RevenueWell

Resolved

This incident is now resolved.
Posted Oct 29, 2025 - 21:11 CDT

Identified

Our webmail hosting provider is currently experiencing an issue affecting some customers who are using webmail.
Posted Oct 29, 2025 - 08:15 CDT
This incident affected: Standard Email Hosting.