Incoming calls being effected

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 10:03 CDT

Monitoring

Calls are processing normal. We will continue to monitor.
Posted Aug 10, 2026 - 10:27 CDT

Identified

A problem has been identified, and a fix has been implemented. Calls are processing normal. We will continue to monitor.
Posted Aug 10, 2026 - 10:24 CDT

Investigating

We are currently investigating reports of an issue affecting inbound calls.  Our engineering team is actively working to resolve the issue.  We apologize for the inconvenience and will provide updates here as they become available.  Should you be experiencing an issue, please email support@revenuewell.com
Posted Aug 10, 2026 - 09:55 CDT
This incident affected: Communications (RW Phone).