Data Processing Delays - DataSync Affected

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 15:45 CST

Monitoring

A fix has been implemented and all data has synced up. We are monitoring.
Posted Jan 27, 2026 - 14:42 CST

Identified

We have identified the source of DataSync delays and are working on improving the performance.
Posted Jan 27, 2026 - 11:52 CST

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. We are working on improving performance and the system should be caught up shortly.
Posted Jan 27, 2026 - 11:42 CST
This incident affected: Data Sync.