Practice Portal Availability

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 20:15 CDT

Monitoring

We've implemented a fix and practice portal has returned to normal. We will continue monitoring to ensure there are no further issues.
Posted Mar 25, 2025 - 18:23 CDT

Investigating

We are investigating an issue impacting Practice Portal which is causing the portal not to load.
Posted Mar 25, 2025 - 18:16 CDT
This incident affected: Portals (Practice Portal).