Phones audio issues
Incident Report for RevenueWell
Resolved
For the last several hours, East Coast consumers have reported their cell service has returned to normal.
Posted Jul 26, 2023 - 14:24 CDT
Monitoring
Cell service providers are experiencing issues impacting patients' ability to place calls to any number. We will continue to monitor as they work to resolve.
Posted Jul 26, 2023 - 08:13 CDT
Update
Some cell phone carriers (like Verizon) are reporting issues on the East Coast which are resulting in "all circuits busy" messages.
Posted Jul 26, 2023 - 07:58 CDT
Investigating
Engineers are investigating reports of audio issues with some incoming calls.
Posted Jul 26, 2023 - 07:49 CDT
This incident affected: Communications (RW Phone).