PolarisMail - Email account access issues
Incident Report for RevenueWell
Resolved
The incident has been resolved.
Posted May 21, 2024 - 11:29 CDT
Monitoring
We identified the issue and access to emails with PolarisMail has now been restored. We continue to monitor the situation and will provide further updates as soon as they are available.
Posted May 20, 2024 - 11:45 CDT
Investigating
We're investigating an incident impacting customers using hosted email. Currently, customers with hosted email through PolarisMail are unable to access their email.
Posted May 20, 2024 - 11:12 CDT
This incident affected: Communications (Standard Email - MySecurePractice).