Data Sync - Delays in data processing

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 15:43 CDT

Identified

Our data sync process is running behind, which is causing delays in updating patient information in the system and writing it back. No data has been lost, and the system should catch up shortly.
Posted Jun 09, 2025 - 09:39 CDT
This incident affected: Data Sync.