Maintenance: Public Payments Page
Incident Report for RevenueWell
Resolved
Maintenance has been completed on the public payments pages.
Posted Aug 26, 2024 - 16:54 CDT
Identified
The public payments page is undergoing maintenance. If you use RW Payments, please direct patients to make payments via their patient portal login while the public page is under maintenance.
Posted Aug 23, 2024 - 11:21 CDT
This incident affected: Patient Payments.