Outbound Calls Not Completing
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 22:55 CDT
Monitoring
Service for outbound calling has been restored. We will continue monitoring to ensure no further service disruption.
Posted Sep 18, 2024 - 09:08 CDT
Identified
We have identified an issue affecting some outbound phone calls, causing these outbound calls to not be completed. We are actively working on a fix with our service provider.
Posted Sep 18, 2024 - 08:19 CDT
Investigating
We are actively investigating reports that some customers are unable to make outbound phone calls. Inbound calls are not experiencing issues.
Posted Sep 18, 2024 - 07:48 CDT
This incident affected: Communications (RW Phone).