Practice Portal Log In

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 11:07 CDT

Monitoring

Customer log in service has been restored. Our team will continue monitoring.
Posted Oct 27, 2025 - 17:21 CDT

Investigating

Users are currently unable to log into practice portal and are receiving a "blocked" message. We are actively investigating.
Posted Oct 27, 2025 - 17:12 CDT
This incident affected: Customer Login.