Service Outage
Incident Report for RevenueWell
Resolved
All systems have been tested and are fully operational.
Posted Jul 19, 2024 - 17:40 CDT
Update
Most RW services are operational. We are continuing to work through some remaining issues with Scheduler and Reputation Management.
Posted Jul 19, 2024 - 14:27 CDT
Update
The Patient Portal, Messenger, and DataSync are operational.
We are currently experiencing issues with the Appointments Calendar and are actively working to resolve them.
Posted Jul 19, 2024 - 11:34 CDT
Update
Practice and Admin portals have been restored.

We are continuing to work on restoring Patient Portal and other impacted services.
Posted Jul 19, 2024 - 10:58 CDT
Update
We have been able to restore some parts of the system, but are still working to restore some of the main components to allow full service to come back online.
Posted Jul 19, 2024 - 10:34 CDT
Update
Our teams continue working to bring impacted services online and will continue to provide updates when available.
Posted Jul 19, 2024 - 09:35 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 08:27 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 08:23 CDT
Identified
RevenueWell services are being impacted from the global CrowdStrike outage. Our teams are working towards restoring services as quickly as possible and will provide updates hourly.
Posted Jul 19, 2024 - 08:01 CDT
Investigating
We are currently experiencing a service outage due to an issue with our cloud vendor. Our team is actively working with the vendor to resolve the problem as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience. Please check back here for updates.
Posted Jul 19, 2024 - 06:54 CDT
This incident affected: Portals (Practice Portal, Patient Portal), Communications (Patient Communications, Messenger), and Data Sync, Appointment Scheduling.