Problems accessing voicemail from physical phones.
Incident Report for RevenueWell
Resolved
This incident has been resolved. Voicemails can now be accessed properly on the physical phone devices.
Posted Feb 28, 2024 - 05:35 CST
Update
We are still investigating the issue with the physical phones. You are able to access voicemail though the RW Phone application.

1. Open the Phone app along the lefthand sidebar menu
2. Click "Voicemail"
3. Choose the voicemail you wish to listen to
4. Click the play icon
Posted Feb 27, 2024 - 08:23 CST
Investigating
We are currently investigating the issue.
Posted Feb 27, 2024 - 07:59 CST
This incident affected: Communications (RW Phone).