Practice Portal Availability

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 15:52 CDT

Monitoring

The Practice Portal Login functionality has been restored.
Posted Oct 07, 2025 - 08:20 CDT

Investigating

Some customers experience an issue during Login Process with error "Page you're looking for does not exist or moved to another location."
Posted Oct 07, 2025 - 07:43 CDT
This incident affected: Portals (Practice Portal).