RevenueWell Portals - experiencing slowness and login issues for some users

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted May 08, 2026 - 10:04 CDT

Monitoring

A fix has been implemented and all portals are now operating normally. We will continue to monitor the situation.
Posted May 08, 2026 - 07:30 CDT

Identified

The issue has been identified and the fix is being implemented.
Posted May 08, 2026 - 07:28 CDT

Investigating

We are currently investigating reports of access issues affecting the RevenueWell Practice, Enterprise, and Patient Portals.
Posted May 08, 2026 - 06:56 CDT
This incident affected: Portals (Practice Portal, Enterprise Portal, Patient Portal).