Rackspace Email Issue - Securemail
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted May 06, 2024 - 09:15 CDT
Monitoring
Rackspace, our provider for hosted email, is currently experiencing issues which impact some RevenueWell customers who use the SecureMail product. Our team is currently monitoring the issue and we will keep you posted as updates become available.
Posted May 03, 2024 - 09:56 CDT
This incident affected: Communications (Standard Email - MySecurePractice).