Web Phones & Screen Pop Incident
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted Aug 25, 2023 - 13:07 CDT
Monitoring
The issue has been resolved. We are monitoring all services.
Posted Aug 25, 2023 - 12:20 CDT
Update
We are continuing to investigate this issue. It also impacts the ability to send outbound faxes and access faxes & voicemails in RevenueWell. Inbound faxes are still being delivered via email.
Posted Aug 25, 2023 - 10:52 CDT
Investigating
We are investigating an outage impacting webphones, screenpop, and accessing the PBX. Service to desk phones is not impacted. Engineers are actively investigating.
Posted Aug 25, 2023 - 10:06 CDT
This incident affected: Communications (RW Phone).