Internal Server Errors in MySecurePractice (TruForm, RevenueWell TV, Email Hosting)

Incident Report for RevenueWell

Resolved

This incident is resolved.
Posted May 06, 2025 - 12:23 CDT

Monitoring

Systems are now back to operational. We will continue monitoring to ensure no further access issues persist.
Posted May 06, 2025 - 10:40 CDT

Update

Customers may receive an Internal Server Error (500) when when accessing MySecurePractice services, including TruForm, RevenueWell TV, and Email Hosting. We are currently investigating the issue.
Posted May 06, 2025 - 10:26 CDT

Investigating

Customers can receive Internal Server Error (500) when polling a form. We are currently investigating the issue.
Posted May 06, 2025 - 08:59 CDT
This incident affected: Forms (TruForm), Portals (MySecurePractice), Communications (Standard Email - MySecurePractice), and Revenuewell TV.