Practice Portal Availability

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 09:22 CDT

Monitoring

Service has been restored to practice portal. We will continue to monitor to ensure no further issues.
Posted Jul 01, 2025 - 08:15 CDT

Investigating

We are investigating an issue that is preventing access to the practice portal.
Posted Jul 01, 2025 - 07:27 CDT
This incident affected: Portals (Practice Portal).