Data Sync - Dentrix - Vendor Outage
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted 10 months ago. Apr 02, 2024 - 11:14 CDT
Identified
Dentrix is experiencing issues with some endpoints, causing RevenueWell customers who use Dentrix to currently experience a broken data sync.

We are working with Dentrix and monitoring the situation. We will post an update here once endpoints will be available again.
Posted 10 months ago. Mar 21, 2024 - 10:51 CDT
This incident affected: Data Sync.