PBHS Hosted Email Login Issue
Incident Report for RevenueWell
Resolved
The issue has been resolved.
Posted Sep 15, 2023 - 12:40 CDT
Monitoring
A fix has been implemented and we are monitoring results.
Posted Sep 15, 2023 - 09:36 CDT
Identified
A small subset of PBHS Hosted Email users are having issues logging in due to an issue with a technology partner. They are aware and engineers are actively working towards a resolution.

We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve the issue. We'll provide updates as more information becomes available.
Posted Sep 15, 2023 - 09:18 CDT
This incident affected: Standard Email Hosting.