PBHS Hosted Email Partial Outage
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 13:28 CDT
Monitoring
Our technology partner resolved the issue, and we are monitoring PBHS Hosted Email availability.
Posted Jun 04, 2024 - 12:51 CDT
Identified
A subset of PBHS Hosted Email users are having an issue with hosted email functionality. Our technology partner is aware and actively working towards a resolution.

We apologize for any inconvenience this may cause and appreciate your patience. We'll provide updates as more information becomes available.
Posted Jun 04, 2024 - 11:14 CDT
This incident affected: Standard Email Hosting.