Phone 2 App - Faxes, Voicemails, PBX Access are experiencing issues
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted Nov 03, 2023 - 11:48 CDT
Update
We are continuing to investigate this issue.
Posted Nov 03, 2023 - 11:48 CDT
Investigating
We have identified an issue with Web Phones, Faxes and PBX Settings.
This is NOT impacting physical phones and voice traffic.
Posted Nov 03, 2023 - 11:26 CDT
This incident affected: Communications (RW Phone).