Webpages Display Issues
Incident Report for RevenueWell
Resolved
The issue impacting webpage displays has been resolved.
Posted Jan 14, 2025 - 14:13 CST
Identified
We are experiencing issues with webpages display due to problems with our CDN provider. Our team is actively working with the provider to resolve the issue as quickly as possible.
Posted Jan 14, 2025 - 13:15 CST
This incident affected: Portals (Practice Portal, Enterprise Portal, Patient Portal, Desktop Application and Screenpop) and Forms (Forms).