MySecurePractice.com - issues with downloading PDFs

Incident Report for RevenueWell

Monitoring

A fix has been implemented. We are monitoring. The service is restored.
Posted Jun 17, 2026 - 09:35 CDT

Investigating

We are currently investigating an issue with pdf downloads on MySecurePractice.com.
Posted Jun 17, 2026 - 09:23 CDT
This incident affects: Portals (MySecurePractice).