Phone Performance/Service Issues
Incident Report for RevenueWell
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 11:30 CDT
Monitoring
A fix has been performed by our service provider and we see phone services returning to normal. We will continue monitoring to ensure service is fully restored.
Posted Sep 03, 2024 - 12:05 CDT
Investigating
We are investigating performance and service issues of RW Phone for some phone customers.
Posted Sep 03, 2024 - 10:28 CDT
This incident affected: Communications (RW Phone).