RevenueWell Customer Portals Experience Graphics or Display Issues

Incident Report for RevenueWell

Resolved

This incident is now resolved.
Posted Oct 29, 2025 - 21:10 CDT

Monitoring

RevenueWell Portals are operating normally. We are still monitoring the Azure Status at https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 12:31 CDT

Identified

We have identified that the ongoing graphics loading issues on RevenueWell Portals and login screens are a direct result of a service disruption within Microsoft Azure. We are continuing to monitor the situation with Microsoft as they work on a resolution.

You can view the official vendor status here: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 11:51 CDT

Investigating

Customers may experience incorrect graphics or display issues on RevenueWell Portals and login screens. We are currently aware of an issue with Microsoft Azure that is affecting the loading of certain resources. We are actively working with Microsoft to resolve this and are monitoring their official status page for updates. https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 11:49 CDT
This incident affected: Portals (Practice Portal, Enterprise Portal, Patient Portal) and Virtual Visits.