Rackspace Email Issue - Securemail

Incident Report for RevenueWell

Resolved

The issue with Hosted Email has been resolved.
Posted Sep 12, 2025 - 06:47 CDT

Monitoring

Our technology partner resolved the issue, and we are monitoring Hosted Email availability.
Posted Sep 11, 2025 - 16:56 CDT

Investigating

RevenueWell Hosted Email platform is currently experiencing issues which impact some RevenueWell customers. Our team is currently monitoring the issue and we will keep you posted as updates become available.
Posted Sep 11, 2025 - 12:01 CDT
This incident affected: Standard Email Hosting.