MySecurePractice.com - issues with downloading PDFs

Incident Report for RevenueWell

Monitoring

A fix has been implemented and we are monitoring the systems.
Posted Jun 16, 2026 - 12:24 CDT

Identified

The issue with PDF downloads on MySecurePractice.com portal has been identified and a fix is being implemented.
Posted Jun 16, 2026 - 11:48 CDT

Investigating

We are currently investigating issues with downloading PDFs on MySecurePractice.com.
Posted Jun 16, 2026 - 10:30 CDT
This incident affects: Portals (MySecurePractice).