Login Issues on RevenueWell OnTheGo Mobile App

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 05:12 CDT

Identified

We have successfully identified the issue causing login errors for RevenueWell OnTheGo users. Our engineering team is working on applying a fix to restore full service.
Posted Jun 30, 2026 - 10:22 CDT

Investigating

We are currently investigating reports of login errors affecting users on the RevenueWell OnTheGo mobile app. Our engineering team is actively working to resolve the issue. We apologize for the inconvenience and will provide updates here as they become available.
Posted Jun 30, 2026 - 10:20 CDT
This incident affected: Mobile App.