Practice Portal Loading Issue

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 16:13 CDT

Monitoring

We've implemented a fix and practice portal has returned to normal. We will continue monitoring to ensure there are no further issues.
Posted Sep 02, 2025 - 12:03 CDT

Identified

We are seeing issues with Practice Portal loading.
Posted Sep 02, 2025 - 10:44 CDT

Monitoring

We've implemented a fix and practice portal has returned to normal. We will continue monitoring to ensure there are no further issues.
Posted Sep 02, 2025 - 10:12 CDT

Identified

We are currently seeing some customers having trouble loading the Practice Portal. We have identified the issue and working on a solution.
Posted Sep 02, 2025 - 09:51 CDT
This incident affected: Portals (Practice Portal).