Sync Issue for Fuse Customer

Incident Report for RevenueWell

Resolved

The issue has been resolved
Posted Sep 14, 2023 - 23:01 CDT

Investigating

There is currently an outage for Fuse customers. Data is not syncing to and from the PMS.
Posted Sep 14, 2023 - 11:32 CDT
This incident affected: Data Sync.