RW Phone - Inbound and Outbound call failures in San Jose region

Incident Report for RevenueWell

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 20:41 CST

Update

We are continuing to monitor for any further issues.
Posted Nov 13, 2025 - 14:45 CST

Monitoring

Our vendor has resolved the issue and we are operational at this time. We are monitoring the incident.
Posted Nov 13, 2025 - 14:45 CST

Investigating

We are currently investigating an issue affecting inbound and outbound phone calls for some of our RW Phone customers in the San Jose region.

Customers in this area may experience intermittent or complete failure when attempting to make or receive calls.
Posted Nov 13, 2025 - 14:37 CST
This incident affected: Communications (RW Phone).